import Foundation
let pattern = #"<img [^>]*?src=["\']data:image/svg\+xml[^>]+>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div>
<img class="bumbum"><img src="data:image/svg+xml,%3Csvg xmlns="http://www.w3.org/2000/svg" width="960" height="640"%3E%3C/svg%3E" />
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)