#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\.0*|(?<=(\..*))0*)$"
Local $sString = "0" & @CRLF & _
"0.000" & @CRLF & _
"" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"" & @CRLF & _
"0.100" & @CRLF & _
"0.010" & @CRLF & _
"" & @CRLF & _
"1.101" & @CRLF & _
"1.100" & @CRLF & _
"1.100010" & @CRLF & _
"" & @CRLF & _
"100.11" & @CRLF & _
"100.10"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)