const regex = /(\.0*|(?<=(\..*))0*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.0*|(?<=(\\..*))0*)$', 'gm')
const str = `0
0.000
10
100
0.100
0.010
1.101
1.100
1.100010
100.11
100.10`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);