re = /(\.0*|(?<=(\..*))0*)$/m
str = '0
0.000
10
100
0.100
0.010
1.101
1.100
1.100010
100.11
100.10'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result