use strict;
my $str = '0
0.000
10
100
0.100
0.010
1.101
1.100
1.100010
100.11
100.10';
my $regex = qr/(\.0*|(?<=(\..*))0*)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";