import Foundation
let pattern = #"(\.0*|(?<=(\..*))0*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0
0.000
10
100
0.100
0.010
1.101
1.100
1.100010
100.11
100.10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)