#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)- (.+)\n?"
Local $sString = "- John" & @CRLF & _
"- Emma" & @CRLF & _
"- Rick" & @CRLF & _
"- Eva"
Local $sSubst = "\g<1> "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)