$re = '/- (.+)\n?/m';
$str = '- John
- Emma
- Rick
- Eva';
$subst = "\g<1> ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;