using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"- (.+)\n?";
string substitution = @"\g<1> ";
string input = @"- John
- Emma
- Rick
- Eva";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}