re = /- (.+)\n?/m
str = '- John
- Emma
- Rick
- Eva'
subst = '\\g<1> '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result