import re
regex = re.compile(r"- (.+)\n?", flags=re.MULTILINE)
test_str = ("- John\n"
"- Emma\n"
"- Rick\n"
"- Eva")
subst = "\\g<1> "
result = regex.sub(subst, test_str)
if result:
print(result)