# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^:\r\n]*:[^:\r\n]*://gm;t' <<< "_pranay_:pranay:104.144.219.145:3128
_ridhoo:rihdonk:104.144.224.242:3128
_shintna_10:shinhana:104.144.235.149:3128
_waled_jr_:ismail:104.144.241.222:3128"