const regex = /^[^:\r\n]*:[^:\r\n]*:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^:\\r\\n]*:[^:\\r\\n]*:', 'gm')
const str = `_pranay_:pranay:104.144.219.145:3128
_ridhoo:rihdonk:104.144.224.242:3128
_shintna_10:shinhana:104.144.235.149:3128
_waled_jr_:ismail:104.144.241.222:3128`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);