import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^:\\r\\n]*:[^:\\r\\n]*:";
final String string = "_pranay_:pranay:104.144.219.145:3128\n"
+ "_ridhoo:rihdonk:104.144.224.242:3128\n"
+ "_shintna_10:shinhana:104.144.235.149:3128\n"
+ "_waled_jr_:ismail:104.144.241.222:3128";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}