re = /^[^:\r\n]*:[^:\r\n]*:/m
str = '_pranay_:pranay:104.144.219.145:3128
_ridhoo:rihdonk:104.144.224.242:3128
_shintna_10:shinhana:104.144.235.149:3128
_waled_jr_:ismail:104.144.241.222:3128'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result