using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"file (?P<path>.*?)( |\/.*?)? (?P<views>\d+).+";
string input = @"file Science/Chemistry/Quantum 444 1
file Marvel/CaptainAmerica 342 0
file Marvel/Avengers/EndGame 342 0
file Math 333 0
file Biology 224 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}