import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "file (?P<path>.*?)( |\\/.*?)? (?P<views>\\d+).+";
final String string = "file Science/Chemistry/Quantum 444 1\n"
+ "file Marvel/CaptainAmerica 342 0\n"
+ "file Marvel/Avengers/EndGame 342 0\n"
+ "file Math 333 0\n"
+ "file Biology 224 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}