import re
regex = re.compile(r"file (?P<path>.*?)( |\/.*?)? (?P<views>\d+).+", flags=re.MULTILINE)
test_str = ("file Science/Chemistry/Quantum 444 1\n"
"file Marvel/CaptainAmerica 342 0\n"
"file Marvel/Avengers/EndGame 342 0\n"
"file Math 333 0\n"
"file Biology 224 1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")