$re = '/file (?P<path>.*?)( |\/.*?)? (?P<views>\d+).+/m';
$str = 'file Science/Chemistry/Quantum 444 1
file Marvel/CaptainAmerica 342 0
file Marvel/Avengers/EndGame 342 0
file Math 333 0
file Biology 224 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);