using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,2}\.\d{1,2}$|^\d{1,2}$";
string input = @"0.01
99.99
01.01
0.0
0.10
99.99
12
1
50
01q75
123447
fhfgh
fgh54654fg4h
5346545454654564654654654
123
?[0-9]([1-9][0-9](.[0-9])?|.[0-9][1-9][0-9]*)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}