package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2}\.\d{1,2}$|^\d{1,2}$`)
var str = `0.01
99.99
01.01
0.0
0.10
99.99
12
1
50
01q75
123447
fhfgh
fgh54654fg4h
5346545454654564654654654
123
?[0-9]([1-9][0-9](.[0-9])?|.[0-9][1-9][0-9]*)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}