const regex = /^\d{1,2}\.\d{1,2}$|^\d{1,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,2}\\.\\d{1,2}$|^\\d{1,2}$', 'gm')
const str = `0.01
99.99
01.01
0.0
0.10
99.99
12
1
50
01q75
123447
fhfgh
fgh54654fg4h
5346545454654564654654654
123
?[0-9]([1-9][0-9](.[0-9])?|.[0-9][1-9][0-9]*)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}