import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,2}\\.\\d{1,2}$|^\\d{1,2}$";
final String string = "0.01\n"
+ "99.99\n"
+ "01.01\n"
+ "0.0\n"
+ "0.10\n"
+ "99.99\n"
+ "12\n"
+ "1\n"
+ "50\n"
+ "01q75\n"
+ "123447 \n"
+ "fhfgh\n"
+ "fgh54654fg4h\n"
+ "5346545454654564654654654\n"
+ "123\n\n\n"
+ "?[0-9]([1-9][0-9](.[0-9])?|.[0-9][1-9][0-9]*)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}