import Foundation
let pattern = #"^\d{1,2}\.\d{1,2}$|^\d{1,2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.01
99.99
01.01
0.0
0.10
99.99
12
1
50
01q75
123447
fhfgh
fgh54654fg4h
5346545454654564654654654
123
?[0-9]([1-9][0-9](.[0-9])?|.[0-9][1-9][0-9]*)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)