# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{1,2}\.\d{1,2}$|^\d{1,2}$"
test_str = ("0.01\n"
"99.99\n"
"01.01\n"
"0.0\n"
"0.10\n"
"99.99\n"
"12\n"
"1\n"
"50\n"
"01q75\n"
"123447 \n"
"fhfgh\n"
"fgh54654fg4h\n"
"5346545454654564654654654\n"
"123\n\n\n"
"?[0-9]([1-9][0-9](.[0-9])?|.[0-9][1-9][0-9]*)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.