using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<v-btn([^>]*color=""primary""[^>]*)+";
string input = @"<v-btn color=""primary"">
<v-btn
v-if=""(!(actionRemove || actionRefresh) || actionCollapsed) && !noActions""
icon
color=""secondary""
variant=""plain""
size=""x-small""
@click=""triggerCollapse""
>
<v-btn value=""ts"">
<v-icon>mdi-language-typescript</v-icon>
</v-btn>
<v-btn
color=""primary""
@click=""isAlertVisible = !isAlertVisible""
>
{{ isAlertVisible ? ""Hide Alert"" : ""Show Alert"" }}
</v-btn>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}