re = /<v-btn([^>]*color="primary"[^>]*)+/m
str = '<v-btn color="primary">
<v-btn
v-if="(!(actionRemove || actionRefresh) || actionCollapsed) && !noActions"
icon
color="secondary"
variant="plain"
size="x-small"
@click="triggerCollapse"
>
<v-btn value="ts">
<v-icon>mdi-language-typescript</v-icon>
</v-btn>
<v-btn
color="primary"
@click="isAlertVisible = !isAlertVisible"
>
{{ isAlertVisible ? "Hide Alert" : "Show Alert" }}
</v-btn>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end