import Foundation
let pattern = #"<v-btn([^>]*color="primary"[^>]*)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<v-btn color="primary">
<v-btn
v-if="(!(actionRemove || actionRefresh) || actionCollapsed) && !noActions"
icon
color="secondary"
variant="plain"
size="x-small"
@click="triggerCollapse"
>
<v-btn value="ts">
<v-icon>mdi-language-typescript</v-icon>
</v-btn>
<v-btn
color="primary"
@click="isAlertVisible = !isAlertVisible"
>
{{ isAlertVisible ? "Hide Alert" : "Show Alert" }}
</v-btn>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)