const regex = /<v-btn([^>]*color="primary"[^>]*)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<v-btn([^>]*color="primary"[^>]*)+', 'gm')
const str = `<v-btn color="primary">
<v-btn
v-if="(!(actionRemove || actionRefresh) || actionCollapsed) && !noActions"
icon
color="secondary"
variant="plain"
size="x-small"
@click="triggerCollapse"
>
<v-btn value="ts">
<v-icon>mdi-language-typescript</v-icon>
</v-btn>
<v-btn
color="primary"
@click="isAlertVisible = !isAlertVisible"
>
{{ isAlertVisible ? "Hide Alert" : "Show Alert" }}
</v-btn>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}