use strict;
my $str = '<v-btn color="primary">
<v-btn
v-if="(!(actionRemove || actionRefresh) || actionCollapsed) && !noActions"
icon
color="secondary"
variant="plain"
size="x-small"
@click="triggerCollapse"
>
<v-btn value="ts">
<v-icon>mdi-language-typescript</v-icon>
</v-btn>
<v-btn
color="primary"
@click="isAlertVisible = !isAlertVisible"
>
{{ isAlertVisible ? "Hide Alert" : "Show Alert" }}
</v-btn>';
my $regex = qr/<v-btn([^>]*color="primary"[^>]*)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}