# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<v-btn([^>]*color=\"primary\"[^>]*)+"
test_str = ("<v-btn color=\"primary\">\n\n"
"<v-btn\n"
" v-if=\"(!(actionRemove || actionRefresh) || actionCollapsed) && !noActions\"\n"
" icon\n"
" color=\"secondary\"\n"
" variant=\"plain\"\n"
" size=\"x-small\"\n"
" @click=\"triggerCollapse\"\n"
">\n\n"
"<v-btn value=\"ts\">\n"
" <v-icon>mdi-language-typescript</v-icon>\n"
"</v-btn>\n\n"
"<v-btn\n"
" color=\"primary\"\n"
" @click=\"isAlertVisible = !isAlertVisible\"\n"
">\n"
" {{ isAlertVisible ? \"Hide Alert\" : \"Show Alert\" }}\n"
"</v-btn>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.