# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:box(?:(?!es)|es)|bag(?:(?!s)|s)|bxs)\K(?=[a-zA-Z])/ /gm;t' <<< "boxes
bags
boxesapple
boxapple
bagapple
bagsapple
unboxesapple
"