use strict;
my $str = 'boxes
bags
boxesapple
boxapple
bagapple
bagsapple
unboxesapple
';
my $regex = qr/\b(?:box(?:(?!es)|es)|bag(?:(?!s)|s)|bxs)\K(?=[a-zA-Z])/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";