#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(?:box(?:(?!es)|es)|bag(?:(?!s)|s)|bxs)\K(?=[a-zA-Z])"
Local $sString = "boxes" & @CRLF & _
"bags" & @CRLF & _
"boxesapple" & @CRLF & _
"boxapple" & @CRLF & _
"bagapple" & @CRLF & _
"bagsapple" & @CRLF & _
"unboxesapple" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)