$re = '/\b(?:box(?:(?!es)|es)|bag(?:(?!s)|s)|bxs)\K(?=[a-zA-Z])/m';
$str = 'boxes
bags
boxesapple
boxapple
bagapple
bagsapple
unboxesapple
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;