import Foundation
let pattern = #"\b(?:box(?:(?!es)|es)|bag(?:(?!s)|s)|bxs)\K(?=[a-zA-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
boxes
bags
boxesapple
boxapple
bagapple
bagsapple
unboxesapple
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)