const regex = /\b(?:box(?:(?!es)|es)|bag(?:(?!s)|s)|bxs)\K(?=[a-zA-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:box(?:(?!es)|es)|bag(?:(?!s)|s)|bxs)\\K(?=[a-zA-Z])', 'gm')
const str = `boxes
bags
boxesapple
boxapple
bagapple
bagsapple
unboxesapple
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);