#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{10}\R\d{3}/\d{2}\R\d{3}"
Local $sString = "1234567891" & @CRLF & _
"abcd :" & @CRLF & _
"111/22 or 111|22 (another format)" & @CRLF & _
"xyz :" & @CRLF & _
"333" & @CRLF & _
"product :" & @CRLF & _
"blablabla 456" & @CRLF & _
"code :" & @CRLF & _
"01010" & @CRLF & _
"serial :" & @CRLF & _
"8888899999" & @CRLF & _
"" & @CRLF & _
"OR" & @CRLF & _
"" & @CRLF & _
"1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")