import Foundation
let pattern = #"\d{10}\R\d{3}/\d{2}\R\d{3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1234567891
abcd :
111/22 or 111|22 (another format)
xyz :
333
product :
blablabla 456
code :
01010
serial :
8888899999
OR
1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)