re = /\d{10}\R\d{3}\/\d{2}\R\d{3}/m
str = '1234567891
abcd :
111/22 or 111|22 (another format)
xyz :
333
product :
blablabla 456
code :
01010
serial :
8888899999
OR
1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end