import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{10}\\R\\d{3}/\\d{2}\\R\\d{3}";
final String string = "1234567891\n"
+ "abcd :\n"
+ "111/22 or 111|22 (another format)\n"
+ "xyz :\n"
+ "333\n"
+ "product :\n"
+ "blablabla 456\n"
+ "code :\n"
+ "01010\n"
+ "serial :\n"
+ "8888899999\n\n"
+ "OR\n\n"
+ "1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}