package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{10}\R\d{3}/\d{2}\R\d{3}`)
var str = `1234567891
abcd :
111/22 or 111|22 (another format)
xyz :
333
product :
blablabla 456
code :
01010
serial :
8888899999
OR
1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}