import re
regex = re.compile(r"\d{10}\R\d{3}/\d{2}\R\d{3}", flags=re.MULTILINE)
test_str = ("1234567891\n"
"abcd :\n"
"111/22 or 111|22 (another format)\n"
"xyz :\n"
"333\n"
"product :\n"
"blablabla 456\n"
"code :\n"
"01010\n"
"serial :\n"
"8888899999\n\n"
"OR\n\n"
"1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999|1234567891|111|22|111|22|333|456|01010|8888899999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")