# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bhighp(?:\s+\w+)*\s+(?:float|[ib]?vec[2-4]|mat[2-4](?:x[2-4])?)(*SKIP)(?!)|\b(?:const\s+)?float\b/lowp $0/gm;t' <<< "const float x;
float foo1;
highp const float foo1;
const highp float foo1;
precision highp float foo2;"