import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhighp(?:\\s+\\w+)*\\s+(?:float|[ib]?vec[2-4]|mat[2-4](?:x[2-4])?)(*SKIP)(?!)|\\b(?:const\\s+)?float\\b";
final String string = "const float x;\n"
+ "float foo1;\n"
+ "highp const float foo1;\n"
+ "const highp float foo1;\n"
+ "precision highp float foo2;";
final String subst = "lowp $0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}