const regex = /\bhighp(?:\s+\w+)*\s+(?:float|[ib]?vec[2-4]|mat[2-4](?:x[2-4])?)(*SKIP)(?!)|\b(?:const\s+)?float\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhighp(?:\\s+\\w+)*\\s+(?:float|[ib]?vec[2-4]|mat[2-4](?:x[2-4])?)(*SKIP)(?!)|\\b(?:const\\s+)?float\\b', 'gm')
const str = `const float x;
float foo1;
highp const float foo1;
const highp float foo1;
precision highp float foo2;`;
const subst = `lowp $0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);