use strict;
my $str = 'const float x;
float foo1;
highp const float foo1;
const highp float foo1;
precision highp float foo2;';
my $regex = qr/\bhighp(?:\s+\w+)*\s+(?:float|[ib]?vec[2-4]|mat[2-4](?:x[2-4])?)(*SKIP)(?!)|\b(?:const\s+)?float\b/mp;
my $subst = 'lowp $0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";