import Foundation
let pattern = #"\bhighp(?:\s+\w+)*\s+(?:float|[ib]?vec[2-4]|mat[2-4](?:x[2-4])?)(*SKIP)(?!)|\b(?:const\s+)?float\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
const float x;
float foo1;
highp const float foo1;
const highp float foo1;
precision highp float foo2;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"lowp $0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)