re = /\bhighp(?:\s+\w+)*\s+(?:float|[ib]?vec[2-4]|mat[2-4](?:x[2-4])?)(*SKIP)(?!)|\b(?:const\s+)?float\b/m
str = 'const float x;
float foo1;
highp const float foo1;
const highp float foo1;
precision highp float foo2;'
subst = 'lowp $0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result