import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[A-Za-z]+ ([A-Za-z ]+)\"";
final String string = ">genus [1] \"Bellatorias obiri\" \"Caretta caretta\" [3] \"Cyclodomorphus praealtus\" \"Dermochelys coriacea\" [5] \"Egernia stokesii badia\" \"Elseya lavarackorum\" [7] \"Elusor macrurus\" \"Eulamprus leuraensis\" [9] \"Eulamprus tympanum marnieae\" \"Lepidochelys olivacea\" [11] \"Lerista allanae\" \"Liopholis guthega\" [13] \"Liopholis slateri slateri\" \"Lucasium occultum\" [15] \"Tiliqua adelaidensis\" \"Tympanocryptis pinguicolla\"\n"
+ ">genusnew [1] \"obiri\" \"caretta\" \"praealtus\" \"coriacea\" [5] \"badia\" \"lavarackorum\" \"macrurus\" \"leuraensis\" [9] \"marnieae\" \"olivacea\" \"allanae\" \"guthega\" [13] \"slateri\" \"occultum\" \"adelaidensis\" \"pinguicolla\" – Kiwi Power 45 secs ago\n"
+ "> species [1] \"obiri\" \"caretta\" \"praealtus\" \"coriacea\" [5] \"badia\" \"lavarackorum\" \"macrurus\" \"leuraensis\" [9] \"marnieae\" \"olivacea\" \"allanae\" \"guthega\" [13] \"slateri\" \"occultum\" \"adelaidensis\" \"pinguicolla\" ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}